So berechnen Sie den drittgrößten Wert mit Duplikaten

Sie können den Maximalwert mit der Max-Funktion berechnen, aber um den zweit- oder drittgrößten Wert zu berechnen, müssen Sie die verwenden GROSSE Funktion .

Wenn es keine doppelten Werte gibt, beziehen Sie sich bitte auf die folgende Formel:

=GROSS(A2:A9,3)

wobei A2:A9 der Datenbereich ist.

Wenn der Datensatz Duplikate enthält, funktioniert die obige Formel möglicherweise nicht.

In den folgenden Daten gibt es beispielsweise zwei größte Werte von 5, und die Formel =LARGE(A2:A9,3) gibt 4 zurück, was den zweitgrößten Wert darstellt. Der drittgrößte Wert im Datensatz ist 3.

Um den drittgrößten Wert im Datenbereich mit Duplikaten zu finden, verwenden Sie bitte die folgende Formel.

=GROSS(A2:A9, ZÄHLENWENN(A2:A9,GROSS(A2:A9,ZÄHLENWENN(A2:A9,MAX(A2:A9))))+1)) + ZÄHLENWENN(A2:A9,MAX(A2:A9) ) +1)

=COUNTIF(A2:A9,MAX(A2:A9)) soll die Anzahl der Maximalwerte ermitteln. In diesem Beispiel haben wir zwei Maximalwerte von 5, also gibt =COUNTIF(A2:A9,MAX(A2:A9)) 2 zurück;

= LARGE(A2:A9,COUNTIF(A2:A9,MAX(A2:A9))+1) soll den zweitgrößten Wert finden, der 4 ist;

= ZÄHLENWENN(A2:A9,LARGE(A2:A9,ZAHLENWENN(A2:A9,MAX(A2:A9))+1)) bestimmt, wie viele des zweitgrößten Werts sind, und gibt 1 zurück;

Im Datensatz haben wir zwei größte Werte von 5 und einen zweitgrößten Wert von 4, sodass der drittgrößte Wert die nächstgrößte Zahl ist, in diesem Beispiel die vierte Zahl.